Invisible type after exporting?

New to Glyphs! Not sure I am using the software correctly. I’ve designed my alphabet (only capital letters - don’t need lowercase). Next I went to File > Export and set the destination to Library > Application Support > Adobe then set up a new folder called Fonts.

Now when I open up a new software, i.e. Indesign and draw a textbook using the font which finds it’s way to the font list okay, nothing comes out! You can highlight the text and change font and size, but when typing in my designed font, it’s literally invisible.

What’s wrong? Have I missed a step??

Do you have closed all paths in all glyphs?
Can you post a screenshot of one of your glyphs?

Did you make sure you typed in caps? A good idea for an all-caps font is to mirror the caps in the lowercase, by choosing Glyph > Add Glyphs (Cmd-Shift-G), and typing:

A=a
B=b
C=c

… and so on. This will copy uppercase A as a component into lowercase a, etc.

Hi there! I am also new to Glyphs and am having the same issue. I have lowercase as well, but nothing is showing up at all.

Like Sophie’s issue, it exports okay, but I’ve noticed it doesn’t preview the .otf file in finder. I’ve included a screengrab of what I’m seeing:

My font was made by importing PNGs from Illustrator. Please let me know if I’m missing a step.

Thank you so much!

Betsy

You need to convert the images to bezier paths (using the trace plugin or drawn manually).
Or you need to setup as a color font.

And inside Illustrator, is it vectors? If so, please read this:
https://glyphsapp.com/tutorials/importing-from-illustrator

Ok, great: how can I install the plugin to Glyphs? I’ve now downloaded it successfully.

Thanks!

The easies is to get it from the Window > Plugin Manager. If you have downloaded it already, just double click the .glyphsFilter file.

Hi George!

So I successfully imported the vectors from illustrator into the Glyphs app, so now I have bezier paths for each glyph.
However, all glyphs are still appearing invisible after exporting. (the same issue as before, when I hadn’t imported the vectors). Is there a setting in exporting that I am missing? Here is what is showing up when I try to open it in any Adobe program:

Are you using the Adobe Fonts folder?
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

That I am, and yet it’s still showing up as invisible. I even tried the trick suggested of dragging it onto my desktop and downloading it through fontbook (to avoid the error message) and still no go. I’m sort of at a loss as to what I could be doing wrong.

Interestingly enough it’s at least previewing in finder, but it doesn’t preview in fontbook or any Adobe programs.

When you have it installed in FontBook once, you might have compromised the font caches. (https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems)

Or you have some strange settings in the font. Unicode Ranges or something?

Looks like that was the issue! Thanks so much. I’ll let you know if I encounter any other problems.