Issue with Masters (toggling masters, exporting otf files)

When I toggle visibility for regular and bold masters, all points become editable even though it should only be the Bold master that is editable.

As you can see in the photo, both the normal and bold master of my nine appears but the normal master is editable even though I’m only on the bold master. How can this be fixed? please help!

The Select All tool is enabled (see the double arrow at the top left). Press Shift-V (or click and hold on the arrows) to switch to Select tool.