Issue with Update


I receive this message every time I try to check for an update:

“An error occurred in retrieving update information. Please try again later.”

Any ideas what might be wrong? I restarted my mac and retried but the problem wasn’t solved.


Download the app from the web site and reinstall. That should fix it.

That worked fine. Thank you very much.

Reinstall over the top? Or do I need to do a clean install? Dropping the new file over the old one still getting the same issue.

I just dropped the new file in the Applications folder and replaced the old one.

@notanotherfolio Did you download the new copy from the glyphsapp web site?

You just need to replace the app.

I re-downloaded the app from this website.

And replaced the app in the Applications folder.

Still getting the ‘An error occurred…’ message.

Can you create a new user, and try there?

I worked out what happened.

The new download is called Glyphs which saved over my legacy version of Glyphs. But the icon was cached so in my dock it looked like I still had both versions and I was obviously opening the Glyphs-2 (not updated app).


Everyone else having problem with the update here are links to directly download the latest versions:

Hey, sorry to restart the thread Im having the same problem now. Just wanted to check if I should re-download the app the free trial or from the update Glyphs link

you can just download the trial version from the website.