Italic of typeface in Font Book but not showing in InDesign

My new typeface family (9 weights) is working, but the 5 italic versions are in Font Book but are not appearing in the menu of the latest version of InDesign 2022 17.2.1
I have tried all day to solve this yesterday
Any tips? Has anyone else had this problem?

Multiple potential issues here.

What are your name settings? Style linking settings? See the Naming tutorial for details.

Do not install the fonts for testing. You may run into a font cache problem. Best to uninstall, empty the font caches, and restart your Mac. Read here how:

If you want to test in Adobe apps, it is much better to use the Adobe Fonts folder:

For the Sans—

Family Name: LDN Queenstown Sans
Master Name: UltraLight
Style Name: UltraLight

Style Linking

For the Sans Italic—

Family Name: LDN Queenstown Sans
Master Name: UltraLightItalic
Style Name: UltraLightItalic

Style Linking
Italic (tick) of UltraLight


Hello, in case you feel comfortable doing so, you can send me the .glyphs file(s) and I will have a look. If it’s not a font cache problem, it is most probably some error in the instance names (which can admittedly get quite confusing sometimes).

The naming setup looks alright to me. I would only suggest Ultralight and Ultralight Italic as style names, respectively. Separating the word Italic with a space from the rest. No need to use camelcase.

Check if you have the full required charset, especially gravecomb exporting in your italics. See this thread:

That’s excellent. Thanks all solved. It was a Cache problem after splitting a huge typeface family into Sans and Serif versions. And now I’m saving directly into a newly created Adobe Fonts folder. It worked.

1 Like