Keep getting "Invalid Character" errors in Feature 'curs'

Hi everyone, I’d like some help here.
Lately I’ve been working on an Arabic font, and everything was running smooth until a couple of hours ago: I was tweaking the glyphs, and deleting some that I didn’t need anymore; then when I tried to save the file, I kept getting these messages:

Any help will be very appreciated. I’d like to understand, for example, what I did wrong, and whether it is possible to access the Cursive folder and apply the changes right there. Thanks.

Can you send me the .glyphs file?

Sent. Thank you.

@GeorgSeifert

Hey Georg, I think I solved the problem. I’ve removed almost all overlaps, and deleted entry/exit anchors (which I don’t like, because I prefer working with components since I’m not done with the font, yet.)
I also noticed that while I was removing overlaps and anchors, the error messages keep directing me to different lines to correct. (I took screenshots if you ever want to have a look at them.)
To tell you the truth, I’m relieved that the problem is fixed; however, I’d like to know what I did wrong, and whether there is another and easier way to fix it.
Thank you.

I would strongly recommend to not remove overlap. It is very helpful while editing outlines and can be done on export.
The error message came from a quote character in an anchor name. Those exit/entry anchors are normally meant to set up cursive attachment. That means that the exit and entry anchors are on the same height.

@GeorgSeifert
Before I removed any overlaps, the first thing I did was to make sure that all anchors are given proper names, yet to no avail. And because I didn’t know what happened and whether it was possible to access the Feature Cursive to correct the code, I opted to remove the entry/exit anchors, too, just because I didn’t need them anyway. (It’s a simple font that doesn’t require any ligatures; I wouldn’t have removed them otherwise.)
So, you think all that headache was because of a simple misspelling? Lol
If it ever happens again, is there a way to go straight to the character, instead of keep guessing?