"Keep Glyphs" parameter stripping CC on export

Apparently the “Keep Glyphs” parameter in the latest Glyphs (3068) removes all corner and cap components before export, resulting in this (pictured “h”):

the idea is that you can remove the caps and corners altogether (of they are quite subtle, you might what to be able to remove them to get the smallest possible file size).
I’d like to find a way to be able to do both. Your case looks like a bug and should work without any further setup. Maybe if they are explicitly mentioned in a “Remove Glyphs” parameter, they should be removed.

Maybe I am missing something but the behaviour changed from Glyphs 2.

Attached is a minimal test case file: just the H glyph with a CC, instance with “Keep Glyphs: H”—the exported file has no CCs.

Keep Glyphs Test.glyphs (7.1 KB)

Yes. This has changed in Glyphs 3. I’ll have a look at it.


Thanks. Any updates? I need to generate trial fonts of an about-to-be-released typeface, so this feature is critical.

I fixed that. Will be in the next update.

The same file ("Keep Glyphs" parameter stripping CC on export - #3 by chrisjansky) still does not work in 3071.

Any ETA on this, please? :pray:

That should be fixed in version 3073.

Thanks for the update. In the test file attached above, yes, but in a real production file with accented glyphs et c I get the following error:

The instance has only the following filter:
Keep Glyphs: .notdef, A, B, C

Shouldn’t the Features get recompiled automatically?

All automatic features should be recomputed automatically.

Well, they aren’t unfortunately. I‘ve modified the Test file by adding a dummy “Hbar” glyph and added automatically updated Uppercase class in File > Features and get an error in export.

Please try for yourself: Keep Glyphs Test 2.glyphs (7.4 KB)

Thank for the file. I fixed it.

1 Like

Perfect! Excited for the update then :pray: