Kerning automatically changes in different masters

Good afternoon everybody,
I came across a possible bug while kerning.
When I adjust the kerning value between two letters in the Regular master, it automatically updates the kerning in the XBold master forcing it to have the same value as in the Regular master. It does the same ting the other way around. I change the value in the XBold and it updates automatically the value in the Regular.

Only thing that I can think about is that the XBold was originally born as duplicate of the Regular master, and that somehow a link between the two masters is created.
Anyone experiencing the same issue?
Working in Glyphs 3.1 (3133).

Can you save, close and re-open the file? If it keeps happening, can you send me the file?

Or do you have a ‘sync metrics with master’ custom parameter in the XBold master?

After closing and re-opening the file it stopped happening.
I have no ‘sync metrics with master’ parameter.
Worth investigating the bug. One might keep a file open for several hours while working on it. Thanks for checking.

How did you duplicate the master?

From the Masters tab in the Font Info, I selected the mastr I wanted to duplicate, pressed the ‘+’ button > ‘Duplicate Selected’.

I fixed it. Thanks for the report.