Kerning in word processors


I’ve created a font using Glyphs Mini (and applied appropriate kerning as needed), but have noticed that the exported font does not show this kerning when it is used in word processors like TextEdit or Pages, to name a few.

However, fonts like Times New Roman do display proper kerning in TextEdit and Pages.

Any thoughts on why this would be?

Thanks for your help!


P.S. The kerning is working in Photoshop and Illustrator, just not the word processors.

Try to open the Font Info Menu and add an empty feature if you have none yet.

Thanks for the reply. I don’t see anything in the Font Info Menu that looks like what you’ve described… do you mind expanding on that a little? (As I mentioned, it’s not the full version… is this still possible in Glyphs Mini?).

Thanks again for your help.

If you have the Mini version, just add a ligature like “fi” or “f_f”. This will generate the feature automatically.

Georg Seifert
Hi Georg - I’ve generated the ligatures already as you’d mentioned… that’s not the issue. The issue is that custom kerning between pairs that I apply in Glyphs Mini (like between the letters ‘V’ and ‘A’, for example) is not actually showing up correctly in word processors. Programs like TextEdit seem to be ignoring all the custom kerning I’ve added to the font altogether.

Am I missing something?

Thanks again, and great work on the app!

It’s confusing but there is an odd bug in some applications where if kerning is the only opentype feature it won’t show up. Adding any second opentype feature (like ligatures) will make the kerning also show up, so is a workaround for that bug.

Hi, and thanks for the link - while that webpage seems to identify the same problem I’m having, unfortunately the provided solution hasn’t worked for me… I had already included several additional ligatures (fi, fl, f_f, f_f_i, f_f_l, f_j) in the font I originally exported, yet the problem was there anyway.

Any further suggestions? Thanks for your help.

Can you send me the .glyphs file ans the .otf file?


generally, there are two possible technical implementations for kerning in a font: the KERN table (which is the more old-fashioned way), and the GPOS table (which is more modern, allows for class kerning). Fonts can have both KERN and GPOS kerning at the same time.

Some text editors such as TextEdit, Pages or Word only apply KERN table kerning, they don’t apply GPOS kerning, although this would be the more elegant approach.

For now, if we want kerning to work in these applications, we need to include KERN kerning in the fonts, unfortunately.

does/can Glyphs generate a KERN table?

Tim, this is not entirely true. TextEdit supports GPOS kerning (at least it works for me).
Word for Windows does not support GPOS kerning, but the OpenType engine in Windows auto generates a kerning table for latin glyphs from the GPOS table. This works only for .otf, not for .ttf fonts.

So if a certain font does not work there is something wrong with it.

I did not ask this before: Did you clean your font caches?

Now I’m confused. Just tested some fonts in TextEdit and found that for some, GPOS worked, for some not (even though they have OT features, which show up in the Typography palette). Will do some research to find out what makes some fonts fail.

Just played around a bit and found out that adding a liga feature doesn’t make GPOS kerning work in TextEdit and Pages, but adding the cpsp feature (capital spacing) does. The latter is supported and even activated by default. At least that’s on my computer.

As a generalisation, my assumption is that a font needs a second GPOS-based feature for GPOS kerning to work.

Is adding the cpsp feature limited to the full version? How might this be added in Glyphs Mini?

Thanks for your work on this.

I will look into this. If it is true that only a cpsp feature will enable the kerning I will add it to the Mini version.

I did some testing as well. I couldn’t get two test kerning pairs to work in TextEdit (OS X 10.8.2), with or without cpsp. Then I copied a large amount of kerning pairs from another font into mine, and suddenly it worked.

So, for now, I believe not only must there be a 2nd GPOS feature, but also a minimum amount of kerning pairs.