Kerning is missing after adding glyphs to the TTF font

I am trying to add language glyphs to some TTF font, though kerning is absent in the final exported font.

When I open the oryginal font in Glyphs there are no kerning pairs visible in kerning window. Though, in Illustartor I see specific kerning values displayed in character window. When I import the oryginal font to Glyphs and export it these values are gone.

Is it possible that Glyphs for some reason cannot import kerning pairs? or maybe there is other way of resolving this issue?

I am really new to this software so I would appreciate crafted for super–early user.

Glyphs does Import kerning. But some fonts are formatted that makes it more difficult. Can you send me the .ttf file?

Sure! Here is the oryginal font:

Here is with Polish glyphs added:

I appreciate your help! Thanks

The font contains a old style kern table. Glyphs should be able to read it but it was broken.

Do you have an idea how can I fix this kerning table myself? thanks for help

Wait for a fix or try an older version of the app.

That was broken for a year or so. So you’ll not be happy with the old version.

Does that mean that Glyphs version that is more than one year old will read this kerning table?

Better try the cutting edge version from yesterday. I fixed it already.

Thanks a lot for including this in update. It solved my issue. Though later I realized not all kerning group were sucesfully imported (probably most of them though). Cheers.

The font does not include kerning groups and only 31 pairs.

There is no such thing as group kerning in (old-style, pre-OpenType) kern tables, hence no kerning groups. Group kerning requires a (OpenType) GPOS table.