Kerning never exported

I am very new here and this is my very first font. I am using Glyphs 3.1.1 on Mac iOS 12.0.1

After I finished kerning all pairs of latin glyphs and tried exporting them out. The kerning I’ve set never exported. All glyphs on Ai, InDesign were like they never been kerned before.

I have tried clear caches, installed the fonts by put it in the Library folder and use Adobe Fonts folder… None of them work

Any suggestion what I have done wrong, did I miss any process or what I should do?

Is kerning applied when you open WindowText Preview in Glyphs?

Any reason why you’re not using the latest version?

Yes, it is applied.

I just downloaded Glyphs around the Christmas time and did not aware that there is an update. Thank you for the information.

I already updated the app but the problem is nor fixed yet.

Could you send the .glyphs file and the Illustrator/Indesign file you are testing with?

Yes sure. To which email or where I should send them?

Send an email to support at this domain (without forum or www) or a link to the file in a direct message in the forum.

They are sent to the email.

The problem is that you used spaces in your kerning group names and that is not allowed. And Glyphs didn’t show an error to explain this. This is fixed in the beta version of 3.2.

I send you the fixed file back.

Many thanks