Kerning not working in Internet Explorer and Edge

I developed two fonts with ~120 and ~170 kerning pairs respectively.
I tested in windows 10 Explorer and Edge to export to CFF and TTF with Glyphs Version 2.4 in woff and woff2 formats.
The fonts are correctly rendered in most browsers like Chrome, Mozilla and Safari but in Edge and Explorer the Kerning is not working.
I added the
Prefix: languagesystem latn dflt;
"Write Kern Table" = 1;

but without any change.

Thanks in advance

  1. Do not use that parameter unless you know exactly what you are doing. The kern table is outdated.
  2. What CSS are you using for activating kerning?

@mekkablue, thank you for the quick answer.

In the CSS stylesheet I am importing a @font-face as follows
@font-face {
font-family: “MM-BackCent”;
src: url(‘fonts/my-font.eot’); /* IE9 Compat Modes /
src: url(‘fonts/my-font.eot?#iefix’) format(‘embedded-opentype’), /
IE6-IE8 /
url(‘fonts/my-font.woff2’) format(‘woff2’), /
Super Modern Browsers /
url(‘fonts/my-font.woff’) format(‘woff’), /
Pretty Modern Browsers /
url(‘fonts/my-font.ttf’) format(‘truetype’), /
Safari, Android, iOS /
url(‘fonts/my-font.svg#svgFontName’) format(‘svg’); /
Legacy iOS */

In many browsers (Chrome…) I don’t need to specify anything else in order to have the kerning working. Should I add an IE fix?

Thanks in advance!

Different browsers have different defaults. Take a look here:

Adding the following styles the problem is fixed:
p {
text-rendering: optimizeLegibility;
font-feature-settings: “kern”;
-webkit-font-feature-settings: “kern”;
-moz-font-feature-settings: “kern”;
-moz-font-feature-settings: “kern=1”;

Thanks a lot!


You don’t need svg fonts any more. Have a look at that thread: