Kerning palette has gone berserk on El Capitan

I’ve updated to El Capitan this morning and this is what’s happening to the kerning groups in any glyphs file:

I’ve tried uninstalling the app and reinstalling. The same thing happens on the latest stable release (2.1.1) and the latest beta (2.2b).

I’ll check this.

1 Like

Guys: Any other problems on El Capitan? I was thinking in doing the update…

Been working in El Capitan since Thursday. I can confirm the troubles with the kerning window. Otherwise, the only problem I run into is the occasional small UI glitch because of the new font. E.g., the style linking check marks in the Font Info look a bit off, but still work.

I fixed the kerning panel.

1 Like

The only problem I have come across was the one I described above. Other than that, Glyphs runs just fine on El Capitan.

Thank you, Georg! Waiting patiently for it show up here.

The update is online

1 Like

Almost there. The kerning classes are working correctly, but the issue still remains on exceptions:

New update is out. I hope I fixed it for good, now.

Hello. I have the same problem like Harbotype. Where can I find the update?

You need to activate the cutting edge version in preferences > updates.

It seems to be fixed now. Thank you, Georg.

Thank you Georg. It works now

My Glyphs 2.2b (814) keeps quitting suddenly, while I’m just drawing paths. I’m running on El Capitán. Are you aware @GeorgSeifert? or is just happening with me?

I posted about the crash in a separate thread. The crashes seem to be related with the new graphical subsystem. It seems that Apple has to fix this.