Kerning problem when exporting

I’ve just finished adding kerning to my font and to the combinations (like: AV, VA, VO, Vo etc…). Then for similar letters (a, ä, à, a) I added the groups (a).
Everything works fine into Glyphs Mini, but when exporting and importing the font in FontExplorer and in illustrator, the kerning is totally different.
I’m I missing something?
Thank You!

This is probably a font cache problem. Read this please:

Thanks for the answer. I have just tried but the kerning is still different. I also duplicated and saved the font with a different name.
But nothing changed.

So, I’m not able to export the kerning groups.

Can you send us the .glyphs file and the .otf you exported?

Sure thanks! I just sent the two files to your mail.

You need to copy the kerning values from the glyph kerning to the groups. Open the Kerning Panel and twice, run “Compress Kerning” from the gear button in the lower right.

Thank you! It works

Hello, I have exactly the same problem with the kerning; when I export the file and I use the font in illustrator the kerning is completly different. I’m using Adobe fonts folder, the kerning setting is on metric and I’m sure 100% that I’m using the right font. I try, as you say, to open the Kerning Panel and twice run “Compress”, but now when I want to export the file compare an advice that says:

"There was a problem writing the file

Subtable Overflow: tableType: OTGPOS LookupIndex: 2 SubTableIndex: 0 ItemName: lookupList ItemIndex: 0"

I cannot export the file, what I can do??

Thank you!

I have the same issue, specifically with greek characters added into kerning groups, and I tried all your proposed solutions, including cleaning caches, adding the font directly to InDesign’s fonts folder, etc. Nothing works. Also, when opening testing the OTF file in FontExplorer X Pro, the kerning isn’t respected, either, which leads me to believe this must be a bug in Glyphs. Any help? Should I send you my .glyphs file?

Edit: I removed one of the characters I was doing the kerning for (specifically epsilon, which I had added to the left group “o”), did it individually and it now works. Still, it seems weird.

Once again, I ran into the same bug. I googled it and, guess what, I found my own post. Guys, this is hindering my kerning work, you really should look into fixing it. :\

As a workaround you can also add the Use Extension Kerning parameter in Font Info > Font.

Could you send me the file?

Hi guys, I am also having problem with kerning since it is not exported although I tried to follow the eliminating font cache problems instruction. I do not know if I missed something but I think I need some help.

Thank you.

I found out the kerning window in my starting menu is empty and I do not know why

  • How do you test for kerning?
  • Static or variable font export?

Window > Kerning shows only the kerning for the current master, current writing direction, and its current search settings (click on the magnifying lens).

I tested the font in both Illustrator (latest version) and Pages as well. Additionally it is static export.

  • Which app version are you using? Glyphs 3.0.3 (3073)?
  • Illustrator: Are you using the Adobe Fonts folder?
  • Testing in if you are using the Test Export option in the Export dialog, you will need to restart

J’ai le même problème à l’export. Le crénage est vraiment bizarre. Je teste mes polices dans InDesign (dossier Fonts).

have you use this: Testing your fonts in Adobe apps | Glyphs
If so, can you send me the .otf and the .glyphs file?

1 Like