Kerning problems - v. 2.6.1 (1195)


#1

Hi,

I use the latest cutting edge version. Version 2.6.1 (1195) and macOS 10.13.6.
There’s a problems with the kerning.

When I open a project or an existing font there is no kerning. “0 pairs”
After close the project and open recent the same project, there is a kerning. “xxx pairs”

I made a new kerning group. Which refers to the following glyphs below: ordfeminine
The following glyphs would be use this kerning group: ordmasculine
But that doesn’t work. All other kerning groups work well. Why?

03


#2

2: a group name is arbitrary and hence does not refer to a glyph. If you want both ordfeminine and ordmasculine to be in the group, both glyphs need to have the same group name in their left group field.


#3

Thanks.
Yes, they are using same group name.
Usually for group naming I’m using the first referred glyphs name.
It was too late. I worked too long.

The lock was open. I didn’t notice that, this caused misunderstanding.
Sorry.

The above kerning problem is real.


#4

I cannot reproduce this. When I open the font and open the Kerning window, all the kerning is there. Can you send me a file where this happens?


#5

This happens not only for one project or font. This happens for every glyphs file and every fonts.
It is the same situation on my MacBook Pro. With so much difference there I have macOS 10.14.2.
Maybe some plugin problem?


#6

Maybe. Try without plug-ins. Hold down option and shift when starting Glyphs.


#7

I got the same results without plugins. [v 2.6.1 (1197)]
I’ll immediately send a file from the problematic ones.
I can say every glyphs file and existing otf is problematic.
Here is a screenshot.

Start glyphs (without plugin) and Open.
There is no kerning. “0 Pairs” (But at the bottom it seems.)


On both computers.

After close the file and Open Recent (select the previous file):
There is a kerning


#8

Maybe the Kerning window does not know which is supposed to be the front document? What about switching document windows (rather than closing and reopening)?


#9

Have you checked that you don’t have a filter set in the kerning panel. Click on the looking glass and then “Reset”.


#10

It’s like it would help. Not very encouraging that for the first time there is no kerning.


#11

Yes, I checked. There is no filter, I pressed the reset several times.
I made a screen recorded video, I’ll send you soon.


#12

Thank you for sending the files. I have the same macOS and app version as you, but I still cannot reproduce the issue, no matter what I do.

  • Have you tried in a different user on your machine?
  • Have you tried redownloading and reupdating the app?
  • Anything in the Console when you open the Kerning window the first time?
  • Deleted the app prefs?
  • Restarted with the Shift key and then restarted a second time without any keys?

#13

Hello everyone,

I am having a similar problem with kern and spacing with my latest version (2.6 -1192) working with arabic. I am not sure if it is something related to the version of Glyphs that I have or some font caché but I am attatching a couple of images (one inside Glyphs and the other in InDesign) showing the problems. Could you point me in a direction to solve this problem?

Thank you so much for any help that you could provide.


#14

Try 1199 or later please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.


#15

hey folks!
My kerning panel looked empty too. After going to a browser, finding this post and going back to Glyphs, kerns appeared again.


#16

It worked perfectly! Thank you so much!


#17

No, I’ll try today.
I tryed this on my MacBook Pro with Mojave 10.14.2 and Glyphs v 2.6.1 (1199) and everything happens in the same way as on my desktop computer. No kerning the first time.

Yes. Nothing changed.

I think nothing. Although I don’t understand exactly.
When I made a video, didn’t run any other app. Only the Glyphs and
QuickTime.

No. How can I delete?

Normally I run without any keys. When I made a video I started with hold down option and shift. As you wrote: “Try without plug-ins. Hold down option and shift when starting Glyphs.”
I have experienced, no matter how I launch it.

What is the difference the restarted with shift key and restarted with option and shift?


#18

I meant restarting the Mac. Holding down Shift deletes caches.

About deleting prefs: that is documented in the Crashes tutorial.


#19

Thank you.

Yes. Nothing changed.

I did it, nothing changed.
Plus I did PRAM reset, but nothing.

Also nothing changed.

:frowning:


#20

Same here. Kerning panel was empty when I opened the file I was working on. After a while all the kerning pairs were there. It seems it needs a time to manage them (?)