Kerning questions

I’m working on kerning and have questions

  1. I have kerning pairs (that I see in the kerning window). I read that on export a kern feature is created automatically and kerning is added to it. Since there is no kern feature created, and when I manually add kern no entries are auto created, I must be misunderstanding this process? When I review the font in Font Goggles kerning is working correctly.
  2. I have a specific kerning issue where I have a ‘Q’ followed by a ‘commaabovecomb’ followed by a ‘wmod’. Just a Q + wmod kerns fine. But with the commabovecomb in the middle the wmod is far to the right. I reviewed the contextual kerning doc, but I’m unsure if this is the proper way to handle a *.comb instance as Q + commaabovecomb are using anchors for positioning. Do I need to create a composite for the Q + commaabovecomb and then apply wmod kerning to the composite (prefer not to).
  1. The kerning feature is not add to the feature list in the Font Info. It is written to the final .fea file. You can check in the Temp folder.
  2. That is tricky. Why not position the comma above and wmod with anchors and that move it apart with some custom positioning. Can you show what you are trying to do?

There are several things going on here, will do my best to explain.
Per your feedback I added this to the ccmp feature:

lookup wsuperiorHigh {
	lookupflag IgnoreMarks;
	sub @Uppercase wmod' by wmod.high;
} wsuperiorHigh;

In edit for ‘Q’ I kerned the wmod -199 and it looks mostly okay

In Font googles lowercase q + wmod looks okay, but q + commaabovecomb + wmod is not kerned
For uppercase Q + wmod all is okay, but as with lower doesn’t work with wmod.high (no kerning and displays wmod (rather than wmod.high) since commaabovecomb is not uppercase.

The commaabovecomb should not interfere with the substitution in ccmp feature as you have correctly used the lookupflag IgnoreMarks;.

And I just tried it myself and it seems to work correctly:

Do you have anchors in the Q and commaabovecomb?

And in a bunch of other letters, too? Can you send me your file? (22.9 KB)

The alphabet:

Please send the .glyphs file.

Oooops, sorry. Here it is. (44.6 KB)

Any hints/suggestions on what I’m doing wrong?

The font you send me seems to work fine for me (I made the kerning much bigger to be more obvious)

and in Indesign.
Bildschirmfoto 2022-02-10 um 14.03.17

Can you send me some strings that don’t work?

I’m probably not understanding how to properly kern Q + commaabovecomb + wmod. I was assuming, that by choosing Features>glyphs composition/decomposition that the sub of wmod to wmod.high would render. It seems that just it is just using wmod. Do I need to enter in wmod.high? If so, if it isn’t in the keyboard, how to I add it in edit? Also, how to I enable rendering of mark positioning in edit (notice that commaabovecomb is not properly mark positioned).

You just kern “Q”+“wmod”. Ignore that it doesn’t look OK in Glyphs. The commaaccent will be ignored in the kerning as it is a Mark. Please test kerning like this in FontGoggles or Indesign.

I’ve been using FontGoggles and the issue I’m struggling with is the Q + commaabovecomb + wmod. In this screenshot there is a .ttf and .otf. Notice how it appears that it doesn’t appear to be performing the wmod > wmod.high sub. Thoughts?

That is strange. It works for me as you can see in the screenshot. Can you try to update to the latest cutting edge version? Activate it in Preferences > Updates.

I upgraded to the latest cutting edge and that didn’t fix the problem. However I noticed FontGoggles was at v1.1.7. Upgraded to v1.4.4 and now all is good. I should have thought of that! Thanks for the help and testing.

1 Like