Kernkraft installation and instructions for use

The plugins are updated automatically. You need to restart the app the get the new code.

Speaking of. Is it still necessary to open the Plugin Manager once, to trigger a fetch?

still crashes.
The Plugin Kernkraft.glyphsPlugin has caused a crash. Please update it by opening the Plugin Manager or re-downloading it from the original source.

Traceback (most recent call last):

File “”, line 506, in action_

File “”, line 1325, in submitButtonCallback

AttributeError: ‘PreferenceWindow’ object has no attribute ‘errorCollector’

App:3.0.2-3055 Plugin:(null)-(null)

That’s exactly what I addressed.
Can you tell me your exact steps please? Maybe also a screenshot of the Kernkraft Window before it crashes.

I think a notification would be appreciated.

BTW, in dark mode kern groups are barely unreadable (black on gray dark)

And since I’ve installed it years ago, I always read Kernkraft 2.0.0 (beta) as window title

Yeah, I forgot that, Just bumped it to 2.1

If you see that, it should show that now.

Also updated the Kerning Class display in dark mode.

However I cannot reproduce the crash.

Yep I see it.
BTW, I see another small bug :stuck_out_tongue: when opening the window, often the shown glyph is not the right one (the one written in text, among left & right arrow). As I use arrow keys, shown glyph gets correct.

I still see the kerning class as black ;( (I’m on Mojave)

The update might not have come through then. Do you happen to have a Github account? If so, it’d be amazing, if you could open issues there. It’s better to keep track of them there.


I have to uninstall and reinstall the plugin manually to see changes…

Version 2.3 should hopefully have addressed all the bugs. Could you please try once more? Thank you so much!

Yes, I am also uninstalling reinstalling and restarting Glyphs 2 once, to see the update.

I have the issue again that Kernkraft isn’t showing up in the Menu. I get this Message:

The last time Glyphs was started, the following plugins crashed.
Remove and reinstall them and make sure all modules are installed and up to date.

I use OSX Big Sur 11.6. I also updated to the newest Beta Version of Glpyhs 3.0.4. I tried to install it manually but same result.

Hello @Mark !
I’m having a similar issue with Kernkraft where I get a crash error every time I open Glyphs:
Traceback (most recent call last):

File “”, line 15, in
import KernKraftModule as KKM

File “”, line 39, in
from vanilla import Window, EditText, Button, PopUpButton, HorizontalLine, CheckBox, TextBox, TextEditor, EditText, Drawer

File “”, line 1, in
from vanilla.vanillaBase import VanillaBaseObject, VanillaBaseControl, VanillaError

File “”, line 2, in
from packaging.version import Version

ModuleNotFoundError: No module named ‘packaging’

App:3.1.1-3135 Plugin:7-2.3.3

This also seems to prevent Kernkraft from appearing in my Glyph dropdown menu. Any ideas on how to fix this?


Uninstall and re-install Vanilla Module

Looks like related to this

and HugoJ is right, please reinstall the Vanilla module. That should fix it, as Georg explains in the linked thread. Hope it helps.

Thanks @HugoJ and @Mark !
Uninstalling and re-installing Vanilla fixed the issue.


1 Like

Hi @Mark , is there a way in Kernkraft I could see lc to UC pairs? Eg oV.
If there is, I need a bit of help finding it.

— Artur