Kernkraft Plugin not working

Hi! The Kernkraft plugin looks really promising. I installed it, but can’t find it. I expected a button, a listing in the filter menu or something comparable. In the Kernkraft wiki and other documentations I don’t find any shortcut or some instruction how to open the Kernkraft window or start the plugin in any other way.

Yes, I restarted the app. I even rebooted. Glyphs Version 2.3 (895)

How do I get this thing running? Thanks!

It might be that the plugin is only compatible with upcoming version 2.4. that will be released, soon.

Ah okay thanks.

  1. Kernkraft should have been working before Glyphs 2.4.

I’d like to investigate on this. Does it work now for you? (I don’t expect, because there have been no changes recently) Please let me know.

  1. Also, once it works, it should appear under the »Glyph« menu, but you still won’t find a pre set shortcut. You will have to create your own, using the Mac OS shortcut settings in the Keyboard > Shortcuts > App Shortcuts preference panel.

  2. Whenever possible, please report issues and requests directly to the respective Github Repository. Otherwise it can easily fall off the table (I just saw this post by accident here)

It doesn’t work in Glyphs 2.4 neither.

Ok, I could have imagined there would an issue reporting form on GitHub. Next time I’ll create an account.

How can I help you investigate? I run Mac OS Sierra 10.12.1. Kernkraft appears in Preferences:Addons but not in the Glyph menu. Since the update to Glyphs 2.4 the Plugin Manager won’t open and ends up in the message “Install Git. Git Command Line Tools are not currently installed, and are required to run the Plugin Manager. Please install them from” I installed it, found Kernkraft installed, reinstalled it. The installing seemed to work: “Kernkraft installed. The Plugin was installed successfully! Please restart Glyphs to use it.” But after a restart the plugin still doesn’t appear. Just in case you understand the gobbledygook, I’ll send you the notifications from the console when installing the plugin in a private message. There are some errors. I don’t know if this refers to my issue.

Hey @GeorgSeifert Could you help us out? We tried to debug via PM and apparently it does not return any Error logs to the console (or Macro Panel). I tried to add another try–except to the plugin and basically there should be enough catches already. I don’t know how to fix it.

I don’t have Sierra installed. Could it be connected to this? Could some AppKit imports be deprecated or so?

Edit: One last try is pending for answer: Maybe vanilla is not installed.

Kernkraft works! Thanks a lot for (unnecessarily) sharing the worries. Now have a great day, sir!

No worries, my bad! I have to warp the vanilla user interface into a catch in order to notice the user about missing dependencies.

I am on Yosemite 10.10.5. I just install Kernkraft plugin but i can’t find it in Glyph meny. Some help please. Glyphs version 2.5.1. Thank you

  1. Did you search in the search bar of the help menu?
  2. Have you all modules installed (e.g. Vanilla)?
  3. Does the Macro Panel say anything?
  4. Does the System Console say anything?