Kotoeri crash not solved yet?

As mentioned many times, Japanese users are having problem with using Glyphs because of the Japanese IMEs (not just Kotoeri, but other third-party ones as well).

Every time I type something while Kotoeri is active, it crashes; in fact, first several key strokes seem okay. This crash behaviour was introduced in Mavericks but the same problem was observed in older OS’s as well with less frequency.

I’d like to hear how close you are to solving this problem (to be honest I want if fixed asap). Not only is it very frustrating, but it also makes Japanese type design with Glyphs impossible.

This bug is very difficult to fix. I’m still on it.

Thanks. Can’t wait for the update!

This is very serious problem for Japanese users.
Please fix this as soon as it possible.
And you should show how to avoid this issue to Japanese users at this time (System Pref> Keyboard >Add U.S. and Change input source from kotoeri).

Tosche told me that disabling the windows compatibility mode causes this problem in 10.9 for other apps, too. Can you try to disable it?

Sorry to report that it’s still happening, though disabling Windows-like mode certainly reduces the number of crashes. I hadn’t reported this to Apple yet (who is more to blame), and I’ve done just now.

Tosche could help me solve the last crash, too. So this seems to be solved.

Yup, this case seems to have been closed today. Very happy I am.

I just uploaded a new beta that should fix the problem.

Thank you guys!