Layered font: rendering problem in Illustrator

Hi all,

Been working on a layered font for the first time, and the way it’s rendering in Illustrator is giving me a headache.

The outermost paths of the base layer are identical to those of the outline layer, but when I place one on top of the other with high contrast between the layer fills I always get visible edges leaking out from the bottom layer.


Black background, white base layer, black outline layer

It’s definitely not due to a difference in the paths or the metrics:

  • Zooming in or out changes which edges of the bottom layer are visible.
  • The problem is the same with the order of the layer styles reversed.

Not exactly a Glyphs issue, but I’m hoping someone here knows if there’s a way to get illustrator to render this better!

You disabled hinting, right?

Other than that there is nothing you can do except maybe a small overlap. There is a rounding problem on the screen. Technically, the paths go through the pixel, and the pixel has to be rendered with anti-aliasing. Put two antialiased pixels on top of each other, and that is what you get.

1 Like

Ahh, OK! I tried disabling autohinting on export from Glyphs, and setting the AI type anti-aliasing preview method to ‘None’ – but I was still exporting from AI with ‘Type Optimized (Hinted)’ anti-aliasing selected. Exporting from AI with ‘Art Optimized (Supersampling)’ anti-aliasing selected has fixed it.

Thank you for the response.


Exported from AI with ‘Art Optimized (Supersampling)’ activated

1 Like

Actually, exporting with Art Optimized (Supersampling) wasn’t the full solution – remembering to convert all text to outlines before exporting was the only way to also get curves to render with the edges of the bottom layer not showing.

1 Like

Thank you for sharing your findings!