License activation not working

Hi. I am having trouble activating Glyphs. I have tried everything in the tutorial, but to no avail. I purchased this license back around 2015, under a different e-mail, that I can send if you want.

Which error message do you get?

Do you have a Glyphs 2 license? You might still have a license for Glyphs 1. You can check the file extension. It should say: .glyphs2License.

I have a Glyphs 2 license, and I have activated it on a couple other computers. When I try to drag it in, it says “This operation could not be completed. No other information is available for this problem.”

Please redownload the application, move it to the Applications folder, and try again.

I have tried that, but I will try again.

Sometimes the license file itself gets damaged. Could you compress it and send it to me by email?

I have sent it to info [edited for spam protection —mekkablue].

Got the email. The license is OK. How did you installed it? Did you drag it in on the dock icon or onto the dialog that pops up when you open the app?

I tried both.

OK. I have tried reinstalling. I have tried both dragging it into the dock icon, the dialog that pops up, and opening the license file with both it closed and open. It still does not work.
EDIT: I will note that I could not find anything in the ByHost preferences. I have made sure read and write permissions are on.

What does not work? Do you get the dialog still?

The error in the log file points into a couple of possible directions. Here’s my shot at it:

Are you using some kind of system optimization tool (MacCleaner, MacKeeper, etc.) or antivirus software (Avast, etc.)?

Are you using iCloud Drive and is the license file on a folder that is being synced?

No to both

The same problem just happened to me, too. I fixed it for me. I upload a new version tomorrow.

Thank you!

Hi, sorry to bother you, but it does not appear like it has been updated. It is still Glyphs 2.5.1-1141 — have you updated it?

Please try activating the cutting edge version. Go to preferences, choose Updates, activate both checkboxes, and click the Update button.

I can’t activate it - preferences are disabled while the dialog for activation is up.

Try this download link then:

Please schedule for a screen sharing session on Monday. Details via DM.