Ligatures don't work in OTF

Hi Georg,

I designed a font (let’s call it Eins) with stylistic alternates, and made two spin-off versions (Zwei & Drei) of that font where the stylistic alternates replace the default forms. I just saved the base font under a new name, keeping the Family name constant but renaming the Instance, then deleted a number of basic glyphs, then removed the .ss0x tag from the corresponding alternate forms.

The three fonts work well – except that Zwei and Drei seem to have forgotten all about ligatures! All three fonts have the same ligature information in their Glyphs files, and the ligatures work correctly inside of Glyphs. However, when I export those fonts to OTF and use them in PowerPoint, the ligatures only work in Eins.

I’ve already tried re-exporting the font to OTF and importing it into Font Book repeatedly – doesn’t help. Maybe it’s a font cache problem? Can you remind me how to clear the font cache…? Or do you know of any bugs that could cause this?


(PS: Apparently this forum does not support em-dashes…?)

Most likely a font cache problem. Remove the fonts, run this AppleScript, then restart and re-install fonts.

Thanks Rainer – could you remind me how one runs AppleScripts? ;oP

Paste the text in AppleScript, save it as a script in ~/Library/Scripts/ and activate AppleScript Editor > Preferences > General > Show Script menu in menu bar. Then run the script from the script menu in the menu bar. To edit the script, hold down the Opt key when choosing it from the menu.

OK, I was able to execute that, but it didn’t help with the problem. I also renamed the font and installed it anew, which also didn’t help.

Finally, I figured out I could solve the problem by copying this line from Eins to Zwei and Drei:

languagesystem latn dflt;

It was part of the automatically created Languagesystems entries for Eins, but not for Zwei or Drei. I don’t know why. In any case, all three fonts work flawlessly now.

This line must always be there when languages are defined. This usually happens automatically. Did you try de- and re-activating the automation?

Yes. That line does not reappear automatically for any version of the font but Eins.