Ligatures not working in InDesign


I’m having some issues with the ligatures, specifically in InDesign. I looked through the forum and wasn’t able to find any info regarding this so my apologies if this has already been addressed in another thread.

I’m working on a project that requires the use of ligatures in order to access special characters. In fact, the whole typeface is in a fictional language. Everything works great in Illustrator and in Word, but InDesign just refuses to acknowledge the liga feature, or maybe I’m doing it wrong. I tested a standard fi ligature using Myriad and it works fine which leads me to believe I messed something up, somewhere.

Here’s a screengrab of the feature in Glyphs.

FYI, I have the latest version of InDesign installed (17.2.1). I have the feeling that it’s something super basic so any and all help is more than welcome.


I just tried a similar setup and it works for me. Can you send the .glyphs and the .indd file?

Hi Georg,

Thanks for the quick response. I sent you a glyphs file along with a very basic InDesign file where I just tested a couple of ligatures. Looking forward to your response.


How are you testing? Are you using the Adobe Fonts folder?

I am using FontExplorer on 2 different computers (1 Windows machine and 1 Mac). I cleared my Indesign Font cache after uninstalling the font on my PC and it didn’t work. I then installed it on my Mac (for the first time ever) and it did not work there either. My client also tested it in InDesign on his Mac but encountered the same issue. It works fine in Illustrator and Word for everyone though, which is what is confusing me the most.

Do not install the font. Use the Adobe fonts folder. This is probably a font cache problem. Read this please: Eliminating Font Cache Problems | Glyphs

Hi Mekka,

I don’t believe it to be a Font Cache issue but just to be certain, I made sure to clean my cache using all three methods (Safe mode, Apple Type Server and Applescript). I then exported the typeface into the Adobe Fonts Folder but the ligatures still do not work in InDesign.

I want to mention that I’ve tried installing the font on a completely different system, on which there were no previous versions of the font and once again, the ligatures work everywhere except in InDesign.

Any other suggestions or help would be more than welcome.


I believe I might have found the source of the problem, although it seems like such a random reason.

The width of my Space glyph was set to 0 (this was done purposely for reasons relevant to the font). Once I changed its value to anything over 0 (200 in this case), the ligature feature started working again in InDesign. I don’t know if this is an Adobe bug or if it’s something within Glyphs, but it now works!

Thanks again for all the help.

1 Like