Line spacing Glyphs 3.0.4 (3092)

All fonts exported in the latest update have a too tall line spacing.
I have tried different fonts. I have deleted all settings. I have made all glyphs within 1100 to -300. I have created a new font with no changed settings at all.
All of them look like the below image: too big space between the lines.
Am I missing something?

I exported the same fonts before the update and it looked like it was supposed to. So it has something to do with the update.

Where do you tested this? Can you compare the two fonts. Use our FontTableViewer, ttx or OTMaster.

Just in the Font Book.
You can’t replicate it?

Font Book is doing strange things sometimes.
Can you send be the two .otf files.

I have sent an example to your support email address.

+1, the same bug, exports from previous version of Glyphs are OK, ones from the latest have 1000 as descent value (must be -200) and line height feels broken.

Right. Fixed that, too.

1 Like

Hi! In Glyphs 3.0.4 (3094) still there’re some unexpected metrics.


I saw that difference and checked the spec. And the spec doest say what sign the descender should have. All it says is something like this: “the distance between the lowest point and the baseline”. And a distance should probably be positive? But it did write a negative value before, so it should keep doing it.

I am also still having issues, it seems like.
At left is the export from two versions ago.
At the right is the export from current version 3.0.4 (3094).

I fixed it.

1 Like

Can’t wait for fixed build! :slightly_smiling_face: