Lo0ks like ttfautohint needs updating


#1

Hi –

I am trying to figure out how a particular weird hinting thing is happening and it looks like one of the options in the ttfautohint options panel (set in Instances) has been deprecated.

40

I just updated Glyphs to 2.5 (1131).

Micah


#2

This has recently been discussed in another thread. You need to reset the strong stem settings to their defaults.


#3

Ah, gotcha, thanks.


#4

The changes to use the new options in ttfautohint are in the cutting edge beta version 2.5.1 (1133), I believe. As @mekkablue mentioned, this was recently discussed here:


#5

That is fixed in version 1133.


#6

Hi Georg, I hope all’s good!
Just exploring this issue in Glyphs 1134 and noticing strange results in the UI.
If I set String stems to GDI and DW, click OK. I look back at the setting and they change to Greyscale + GDI like so…
From:
12
To:
20
And it seems there’s no way to select DW? Whenever I select it and review the parameter, it shows GDI:
35
Deselecting everything defaults to:
53
Please advise :slight_smile:


#7

Ah just seen the other post from April 16. Is this still the advised setting? Or since the fix should it be working as expected in 1134?
P.


#8

Hi @GeorgSeifert

I have updated to the cutting edge version and set my ttfautohint settings to default (the only thing checked is GDI Cleartype and that is the “dash” check and not the :heavy_check_mark:) and I get this crash when exporting TTFs and autohinting turned on.

44

Thoughts? Thanks –
Micah


#9

There was a bug in parsing the setting when the dialog is shown. If you set the options and export, the option are fine. Only re-opening the dialog shows them wrong. I have fixed that.

I can’t reproduce the crash. Did you send a crash report with a note about this?


#10

Well, it froze and I did cmd+opt+esc on it, but I guess it didn’t actually crash, as it didn’t give the option to send a report. ~And now generating fonts with autohinting turned on, default options, works fine. :man_shrugging: Sorry for the false alarm. I’ll come back if it happens again. Thanks.~

Okay, it doesn’t work. It looks like when I hit export before, no fonts came out. Now, same error. Is there a hidden log somewhere that would help?

(Looks like tildes don’t give strikethrough.)


#11

Yes, checkbox status: Grayscale off, GDI dashed, DW off. That seems to be the only setting ttfAutohint will accept now. Or at least some combinations of string stem settings are OK, some are not. I now always leave them at their defaults.


#12

The latest version should work.

But I don’t understand why one would like something else than the default :wink:


#13

@GeorgSeifert @mekkablue
Ah I see it works now :slight_smile: but only in the cutting edge version — 1136.
As a team we only ever use the stable version of the app. Are there any plans to release Glyphs 5.1 (1136) as the ‘official stable release’? It would be super helpful for us :wink:


#14

Version 2.5.1 is about to be released very soon.


#15

Hello –

I am using 2.5.1 (1137) and I still get the same error when exporting and Autohint is checked. If I have the default settings for TTFAutohint Options set in the instance I get the error; if I don’t have a custom parameter set for ttfautohint and Autohint is checked for export I still get the error.


#16

I’m afraid that 2.5.1. (1138) continues to have this problem. :frowning_face:

Micah


#17

Cannot reproduce. Can you send us the .glyphs file?


#18

Perhaps this is a good time to mention that you can also run an older version of ttfAutohint with Glyphs. There is a Font Info > Font parameter called TTFAutohint binary path for exactly that. As value, you supply the path to the binary of your ttfAutohint installation.


#19

Hi, sorry about the delay, I was travelling. The file in question is on github. Thanks for looking into it.

Micah


#20

Also, let me know if you get this error as well. It happens in stable Glyphs as well as beta Glyphs, and only when Autohint in export is turned off.

20