Locked Kerning not functioning?

In the handbook, the kerning lock icon at the bottom right of the edit view is supposed to control the view and editability of kerning data. Despite that To with padlock icon is supposed to prevent change in kerning according to the handbook, it does allow me to change it. Am I doing something wrong or is it in fact a bug?

The kerning lock is locking the spacing, and not the kerning. This is a error in the handbook and it might need a better icon. The idea is to prevent changed of the spacing if you miss the option key while kerning.

I see. Solved.

Fixed in the upcoming version.