Macro Panel not workingin Glyphs 2.5

Hey there,

The title is explaining itself. I was looking for GSLayer methods in the Macro Panel and it isn’t working. It simply doesn’t run the code. I tried to put some basic mathematical operations just in case and it doesn’t run the code too.

Is anyone having the same problem?

Thank you in advance.

Can you send a screenshot?


Here is a screenshot of the problem. Maybe it doesn’t help but the output is blank when I’m running both help(GSLayer) or 2*5.

Thank you so much for any help.

the first example would only do something if you do print 2*5. The second should indeed show things in the lower panel.

Are you clicking the Run button? Or pressing Cmd-Return or Fn-Return?

True, Georg! I was missing print in the mathematical operations.

I tried both Run, cmd+Run and now I also tried fn+Run and it doesn’t work either.

Can you check Preferences > User settings > User system console for script output? This should not be set.

Oh, that was the problem. Thank you so much Georg.

Which is the difference between setting and not unsetting this box?

Thank you again.

Of you check the box, the output will show up in That might help if the app crashes and you can’t see the output as the macro window goes away.

1 Like

Nice! Thanks a lot, Georg!