Macro window opens at the start

everytime I open the glyphs app, macro window opens.

Is there a way to make it not to open automatically?

Thanks

Close the window, quit the app. If that does not do it, delete your preferences or check your writing permissions in the Preferences folder.

Does it say something in the lower half of the window. Maybe a plugin is reporting an error and opens the window?

This is the only file in /Users//Library/Preferences/

image

This is no preference plist for the app.

I have access to this folder. I was able to delete old plists from other apps without needing any permissions.

Also I check this user login has read/write access.
Should I do anything else?

The preference file should be com.GeorgSeifert.Glyphs2.plist. But if it is not there, then you have a problem with your system. and maybe you have one in /Library/Preferences/?

nope, its not in neither of the location.

Should I uninstall and reinstall?

Do you have writing permissions in ~/Library/Preferences/?

Yes. I deleted few files and added few to test.

Uninstalling will not change anything.

You could run Disk Utility and start into Save Mode to try to fix your system.

can you please give me the default content of the preference file, I will save it in the folder, perhaps it would fix the issue.

Please open Glyphs, close the macro window and quite the app. Then run this command in the Terminal.

defaults read com.GeorgSeifert.Glyphs2 showMacroPanel

it should print 0.
This command can change the setting:

defaults write com.GeorgSeifert.Glyphs2 showMacroPanel -bool NO

If is not working, you could try this. It will ask for an admin password.

sudo defaults write com.GeorgSeifert.Glyphs2 showMacroPanel -bool NO

terminal printed ‘0’

command was completed.
when glyphsapp was reopened. macro window flashes again

I also tried

sudo defaults write com.GeorgSeifert.Glyphs2 showMacroPanel -bool NO

same result.

Which plug-ins do you have installed? I assume a plug-in is opening the macro window during the app start.

Please make sure that Glyphs > Preferences > User Settings > Use system console for script output (towards the bottom) is OFF.

Have you tried starting without plugins? Hold down Opt+Shift when you start the app.

thanks.
macro window doesn’t start with app in safe mode
also, I can glyph plist in preference folder
image
Should I try to remove plugins few at a time and identity the plugin with error to isolate the problem.
Or is there a easier way to isolate the plugin that is causing the problem?

I would try searching for file content ‘showMacroWindow’ inside the Plugins folder. Not sure it works though, so you may end up partially removing plug-ins and restarting anyway.