Make Component Glyph problem

Hi there,

There is a strange behavior of Make Component Glyph function. It sets mark with Automatic Alignment off.
Take a look:

Which app version? Does it also happen in other glyphs? And did you make sure your Font Info > Other Settings is alright?

Version 2.4.1 (956)

All glyphs are affected.
I didn’t change settings:

Oh, all marks have Automatic Alignment switched off. I don’t have to use Make Component Glyph function. :[

I believe this is a bug in 956. Make Component Glyph seems to only align the first component in diacritic compounds. But they are reported as aligned when you query them via Python.

Here is a quick fix. Select the master and glyphs you want to have auto-aligned, and run this from the Macro window:

for l in Font.selectedLayers:
	for c in l.components:
		c.automaticAlignment = True


There is one more thing which seems to be related to this problem:

weird behavior of right sidebearing when all _part components are set to auto-align. When first is disabled it works ok.

Try #entry and #exit anchors instead.

I’ve a similar problem since moved to Glyphs 2.4.1 …
Eventually no control on Metrics update !!
A demo video:

@Avantino: Can you send me the .glyphs file? I will have a look.

I fixed that.

@GeorgSeifert I’ve reported this issue before; assuming that the problem relates to components which are not identified as Unicode or Glyphs;
After running “Update Glyph info” and “Update Metrics” commands; all glyphs that corresponds to those components do not get updated in terms of LSB & RSB … particularly if it is set to = "component name’
Besides that the "Enable Auto Alignment " issue as discussed through recently !

@mekkablue I will email you the file … as it bears another issue concerning OT features raised in a previous post;
Would appreciate your inspection.

Can you try version 957 that I uploaded earlier today?
Can you send me the file, too (to support at this domain).