Make glyph names lowercase doesn't work properly

Hey there,
I tried to rename the sc-Glyphs to lower case names, but neither the mekkablue script nor the geeky way (find (.*).001 replace \L\ does change the names of the alphabet letters to lowercase. However, the switch from 001 to sc does work.

I updated to the latest version, but still doesn’t work.

Would you check that, please?
Best, Anita

This is called a regular expression and therefore the Regex option must be switched on. It works as expected in Glyphs 2.6.6 (1346) on Mojave:


The script also works for me. If it does not convert something, it will tell you why in the Window > Macro Panel, e.g.:

Converting 6 selected glyphs to lowercase:

:x: C: cannot convert to c, glyph already exists.
:x: D: cannot convert to d, glyph already exists.
:x: E: cannot convert to e, glyph already exists.
:x: M: cannot convert to m, glyph already exists.
:x: N: cannot convert to n, glyph already exists.
:x: O: cannot convert to o, glyph already exists.

0 glyphs converted to lowercase.

The report at the Macro Panel found the error: Because I already had a it stopped and didn’t convert anything.

Thank you a lot and have a nice summer!

1 Like