MakeOTF error Coverage offset overflow (0x16732) in pair positioning

Trying to export a font with 9468 kerning pairs. (Exported fine before I started kerning.) I’m getting the error: “MakeOTF error Coverage offset overflow (0x16732) in pair positioning”. I’ve read previous threads suggesting to remove some kerning pairs. I wouldn’t want to do that since all the pairs are needed, and besides, I don’t know how many need to be removed in order to avoid this error. Am I missing something here? Is there a limit as to how many kerning pairs are allowed in a font?

Why do you have 9000 kerning pairs. That sound quite a lot. There is a discussion about this in typedrawers: http://typedrawers.com/discussion/2313/efficiency-in-kerning-pairs#latest

Did you read this: https://glyphsapp.com/tutorials/kerning

You could try to add a Use Extension Kerning parameter to the font. But I VERY strongly recommend that you reduce the number of kerning pairs.

That is about 150% of what is possible to squeeze into a font.

But I agree that 9k kerning is a ridiculously high number of pairs, which usually indicates bad spacing.

  • Consider optimizing your spacing, and making a lot of kerning superfluous: https://glyphsapp.com/tutorials/spacing
  • Are you using group kerning? If so, can you try to get rid of exceptions? (The Compress Kerning function helps.)
  • Do you have many small kerning pairs? There is a script in my repo that deletes small kerning, like everything below 10 or 15 units.
  • Do you have many similar kern pairs? There is a script in my repo called Adjust Kerning that can round kern pairs, so you can better compress them.

How many glyphs do you have in your font? And how many different scripts are you supporting?

The “Compress Kerning Function” took care of the problem.

FYI: The font has 978 glyphs, which includes: Upper case, lower case, Titles, pcaps, 2 upper case [A-Z] stylistic sets, 2 lower case [a-z] stylistic sets, some ligatures, Numbers, Fractions, Punctuations, Symbols, Marks. It supports Basic Latin, Western Europe, Central Europe, SE Europe.
There’s nothing kerned less than 10 units. The font is very well spaced. The reason there are so many kerning pairs is because most characters are designed with twirls extending farther out of the glyph than usual which cannot be addressed properly with basic spacing.

Thank you all.

Hi guys,

I have the same problem with exporting my fonts. The MakeOTF error I get is: Coverage offset overflow (0x1a50a) in pair positioning. I have the problem on 4 font files…

I have used Rainer Erich’s script to Delete small kerning pairs and Adjust Kerning. I compressed the pairs and have about 2500 now. Nothing changes, still can’t export :grimacing:

What do I try next?

Glyphs version is 2.4.2 (1060)

Enable Extension Kerning with the custom parameter by the same name in File > Font Info > Font > Custom Parameters.

How many glyphs do you have in your font and how many kern pairs?

Use Extension Kerning didn’t help.
~850 Glyphs ~2400 pairs

This seems like an awful lot of pairs for so few letters. You may want to consider improving your spacing, and thus, avoiding a large percentage of pairs.

:sweat: I will try to do so

I made a few tests and found that having the same amount of kerning pairs in both of the masters makes it work.