MakeOTF error - found something causing it

I know this has been covered quite a bit here on the forums, but i just bumped into the dreaded ‘MakeOTF’ error.
Luckily I had been saving versions, so I went back to the last working one, then, using the next saved version, deleted single characters until i got it working again. Once i found the character causing the problem, I noticed that I had a tiny path segment exactly overlapping a separate closed path. I deleted the little redundant segment, and the MakeOTF error went away.

Hope this helps someone.

1 Like

Can you post a screenshot of the path arrangement that caused the trouble?

sure @mekkablue

this isn’t the whole letterform, but this is the piece with the overlap:

on the right hand side, that’s an 8 x 8 curve:

and this is the piece - that i moved to the right so you could see it - that i deleted:

Interesting. The Remove Overlap option in the Export dialog should remove open paths automatically.

ah, that makes sense. i have that option unchecked for now.