MakeOTF error: MarkToBase or MarkToMark

i want to export a font I’m working on, without any
otf-features defined yet.
but I get an error: MarkToBase or MarkToMark error 0(+1, +2): A previous statement has already defined the anchors and marks on this the same glyph ‘i.loclTRK.1:i.loclTRK.1’. Skipping rule.
—> is there a way to not have MarkToBase or MarkToMar features while exporting?

using Version 2.0.1 (736)

also tried
— to “Disable Subroutines” in each instance
— to go with and without the letter “i.loclTRK”

the error message is speaking about the letter ‘i.loclTRK.1’ (with a one at the end). There seems to be something wrong with the anchors in that glyphs.

ah, ok.
but the strange part is: my font does not contain such character.
I just send you the file to support@

But maybe both idotaccent and i.TRK next to each other? Delete or disable one of them.

Just had a look at the file you sent us. There are two idotaccent glyphs. Remove one of them, and it is going to export just fine.

thank you. that works.

Hi all,

First: what an amazing app you guys have made! I’m still on trial time and I’m beyond impressed.

Now, I seem to run into the same problem as jakob_runge. The error message speaks of a glyph called but that glyph does not exist.

uni1EE9 is the ‘uhorn’ glyph and I did duplicate that glyph to make the corresponding smallcap, but that glyph is not named and when searching for nothing is found.

What’s going wrong?

Best, Alex

  1. Do you have both uhornacute(.sc) and uni1EE9(.sc) in your font?
  2. Is there any particular reason why you don’t use nice naming in Glyphs?

Hi mekkablue,

I did a search for ‘uhorn’ and got this (and you where right, it’s not uhorn but uhornacute)

Turns out I DO have a duplicate glyph:
I suppose I got caught by the error message referring to the glyph by un-nice name instead of nice name :smile:

Another mystery solved, thanx a lot.