MakeOTF error-Syntax Error


#1

Hi!

I have a trouble generating a font.


It would be great if I could get some help from you guys!

Thank you very much!

With Thanks,
Jung


#2

Read this please:
https://glyphsapp.com/tutorials/troubleshooting-a-font-that-does-not-export

Do you have a handwritten mark feature in File > Font Info > Features?


#3

Thank you for your quick reply.
Before I posted, I read the page already that you linked. The thing is I don’t get the pop-up dialog titled makeotf error.
I just automatically updated the features tho…


#4

Does it work with features automated?
If not, please send me the .glyphs file to support (at) (this domain).


#5

I’ve sent you an email yesterday because the automated features don’t export the font. I am wondering if my email found you well. Could you please let me know if you haven’t received my email?

Would be great to hear back from you.
Thank you very much!


#6

I am currently traveling and access to good internet is scarce. Please allow a little time.

In the meantime, please check for double unicodes or illegal glyph names. (My first guess.)

EDIT: Your .notdef glyph inherited the anchors from the components you put in there. Two options: Either deleting .notdef, or opening .notdef, decomposing (Cmd-Shift-D) and resetting anchors (Cmd-Opt-U) take care of it.

Advice 1: Your .notdef design is misleading and therefore wrong. Do not make your .notdef a letter compound. The idea is that it must be spotted quickly and easily, because .notdef is what is displayed when the user tries to type a character the font does not support. Make it blocky, big, standing out. If you want a place for your logo or foundry name, better use apple (Unicode F8FF).

Advice 2: Using exclusively figures for your style name (in File > Font Info > Instances) is a bad idea, because it will not work in all environments. I recommend using a ‘normal’ style name like Regular etc., because some environments expect that.


#7

I got it solved! Thank you very much!!!