makeotfGlyphs [FATAL] not in Font Menu Name database


#1

When I export to the OTF, nothing happens because of an error. here it is:

makeotfGlyphs [FATAL] not in Font Menu Name database [DirtyEgoCyrillic-]

I do not understand this error. What should I do to export the results of my work?

P.S.: I found a thread in Adobe Forums that includes similiar error.


#2

Did you put a name in the Font Info > Instances > Style Name?


#3

Hallo,

ich habe ein ähnliches Problem. Wenn ich meine Schrift exportiere, wird plötzlich (nach Hinzufügen weiterer Glyphen; sonst habe ich aber keine Einstellungen verändert) der Fehler „makeotfglyphs“ angezeigt.

Es wird dann aber doch eine funktionierende .otf-Datei exportiert, bei der allerdings die neu hinzugefügten Glyphen dann fehlen!
Woran könnte der Fehler liegen?

Vielleicht kann mir ja jemand helfen, das wäre toll.
Danke schon einmal.

carmen


#4

@Grawl: to elaborate on what Georg asked you, there should be a style name (like ‘Bold’) in the error message after the dash in [DirtyEgoCyrillic-]. I suggest you go through the font info settings and make sure all fields are entered correctly. Also check for non-ASCII and whitespace characters and the like.

@carmen_grinsekatze: Überprüf mal deine Fontinfo-Einstellungen. Wenn das nicht hilft: Kannst du die .glyphs-Datei kurz online stellen oder mal schicken an mekka klammeraffe punkt com?


#5

Hallo mekkablue,

in den Fontinfo-Einstellungen müsste alles passen, ich hab seit Monaten daran nichts verändert (außer bei den Features, allerdings habe ich dort seit dem letzten funktionierenden Export auch nichts verändert). Auch wenn ich jetzt testweise alle Glyphen und alle Features lösche, erscheint der Fehler.

Lieben Dank für das Hilfsangebot mit dem Schicken, aber es steckt wirklich sehr sehr viel Arbeit in meiner fast fertigen Schrift, da schick ich sie ungern an eine fremde Person.
Hast du vielleicht sonst noch eine Vermutung, woran es liegen könnte?

Viele Grüße
carmen


#6

@carmen_grinsekatze: Ohne die Datei können wir aber nicht viel helfen.


#7

@carmen_grinsekatze: 1. Features löschen und neu anlegen könnte helfen. Womöglich steht ein Glyphenname noch in einer Klasse und die Glyphe heißt mittlerweile anders oder ist gelöscht.

  1. Vielleicht hast du einen ungültigen Glyphennamen im Font? Keine Umlaute, keine Leerzeichen usw.

Ad schicken: Wie du magst, ist ohne Datei aber eher Blindekuhspielen. Was könnte ich denn anrichten? Ich nehme dir die Schrift ja nicht weg und unter meinem Namen kann ich sie ja auch nicht herausgeben. Was hätte ich davon, außer einen ruinierten Ruf?


#8

Danke nochmal für die Tipps. Leider seh ich mittlerweile anscheinend den Baum vor lauter Wald nicht…
Ich schicke euch also dann doch mal die Datei, bevor ich hier gänzlich durchdrehe. Danke schon mal!!


#9

Das Problem war ein Leerzeichen in einem Buchstaben Namen. Wie das passierten konnte, da doch die Eingabe überprüft wird?

The problem was a space in one glyph name. This should not happen as the input will be validated.


#10

@Georg: Since which version? Maybe she started the project in a version before the validation was introduced?


#11

Hi,
I’m experiencing the same issue. The pop up message states:
"makeotfGlyphs [FATAL] not in Font Menu Name database"
I went through my font info and everything seems correct. Any other suggestion to loose the problem?
Thanks


#12

There’s a bug in the beta version 1.3.26 (530) that seems to cause this message during compilation of the OpenType features. I believe Georg is aware of it and may have a fix in the works. In the meanwhile, try restarting Glyphs. That pop-up may go away after the restart. At least it did for a quick test I made, earlier.


#13

Thanks, this solved the issue.


#14

I uploaded an update that should fix this.


#15

Hi there,

I’m experiencing the same issue. The pop up message:
makeotfGlyphs [FATAL] not in Font Menu Name database

which wouldn’t allow me to export the font. My version is up to date, tried to restart the program but message would still pop up.
Please help me to solve this problem.
Thank you


#16

Then there might be something wrong with your font name. Did you read this: https://www.glyphsapp.com/tutorials/troubleshooting-a-font-that-does-not-export


#17

I have Glyphs Mini app and struggling to find Script folder
I’ve managed to find Temp folder on my mac but the folder content is irrelevant.
So at the moment I can’t export any of the fonts I have done so far.


#18

What is the Name of the font you want to export? Can you post a screenshot of the font info?

I suspect a missing or illegal style name.


#19

Thank you!

It solved the problem. As soon as I added “Style Name - regular” I don’t experiencing this problem anymore :slight_smile: For some reason I have deleted it. Thank you so much for your help and patience

Sunny Regards
Natalia


#20

I encountered this problem.
1
Style name is added to the instance.
2
generateFont.command doesn’t reveal the cause of the problem:
generateFont.command.zip (848 Bytes)