Making diacritics with stylistic alternates

I would like to use my stylistic alternates with diacritics, I have followed what the website said
(Stylistic sets | Glyphs)
copied the glyphs and changed the name from .001 to .ss01
but the character remains the same…not the alternates?

Then I followed the last step
“And finally, select those .ss01 glyphs and choose Glyph > Make Component Glyph (Opt-Shift-Cmd-C).”
the character did changed to the alternate, but it shows an “empty base glyph”
Then I noticed that some new marks glyphs have been added such as “dieresiscomb”“circumflexcomb” etc
I added those xxxxcomb glyphs, go back to my letter and delete the “empty base glyph” thing
make component glyph, then the mark shows on my letter but in the wrong position…

is there any way to do alternates with diacritics faster??
Thanks a lot!

I cannot reproduce the problems you have. It works at first trial, no empty glyphs, no nothing. Which version of Glyphs are you using?

Did you read this:
Specially the part about anchors?

I think the problem is because I added the “Legacy (Mark)” instead of the xxxxcomb glyphs. After I deleted the “Legacy (Mark)” and added back the xxxxcomb glyphs, the “empty base glyph” problem solved.

Well… I didn’t read about the anchors part…:sweat_smile:
This solve most of my problem! Thanks! but still 1 question:

I have added anchors to my base letters (a b c d e…)
Do I have to added anchors to each one of the letter manually?
I found that if I added anchors to my a (that is open “a” glyph, hit cmd+U), the marks will go to the right place (top middle of the a)
If I did not add anchor to the letter (eg. c) the mark will go to the top left, not top middle…

You need to add anchors to all glyphs. But you can do that by selecting them all in the font view and press cmd+U


When I make a new stylistic sets, the app always use the “default” diacritics.
If I am right, in every case same accents.
There is a way to use alternate diacritics?
I mean that, always use the “default” diacritics (acutecomb, cedillacomb, circumflexcomb, dieresiscomb …), except exists the alternate variation of diacritics with same suffix.

For example: If exist acutecomb.ss03, cedillacomb.ss03, circumflexcomb.ss03 … use this accents for stylistic sets 03. If doesn’t exist, use the default diacritics (acutecomb, cedillacomb, circumflexcomb, dieresiscomb …).

Or does it exist and I do something wrong?

As fas as I can see it works as expected. How do you add the new stylistic set glyph? You could run Make Component Glyph from the Glyph menu to fix it later.

1 Like

This is how it works. But the glyph needs to be generated with that name already, through Glyph > Add Glyphs… and then entering the name.

Simply renaming an existing glyph to .ss03 will not change its contents. In that case, you would need to regenerate it with Cmd-Opt-Shift-C.

1 Like

Thank you @mekkablue! :slight_smile:
That was the problem.
That’s how I did it: duplicated, modified and renamed the glyph to. ss03. But I didn’t regenerate with Cmd-Opt-Shift-C.
Working! :slight_smile:

Thank you @GeorgSeifert too.

Is there a way to generate a Î with Cmd-Opt-Shift-C , but using a I +

You can put it in your (local) GlyphData.xml.

Why do you need that? What is the name of the base glyph?

This is probably easier solved with a small script.

Thanks @mekkablue. But that way the XML file will affect all my glyphs files, right?

@GeorgSeifert, I have a different circumflex for the I. That’s why I want to build Icircumflex with an alt comb. But do you have another suggestion?

If you create/edit the GlyphData.xml file in your ~/Library/Application Support/Glyphs/Info/ directory, then it will be used for any .glyphs file you open. If you put your personal GlyphData.xml file in the same directory as your .glyphs file, then it will only be used for those Glyphs files in that directory.