Making global guidelines local

I’m trying to evaluate the demo version of Glyphs 1.4.4 and I’ve run into a problem with switching guidelines from global to local.

When I select a global guideline and attempt to cut it, it seems like nothing happens. In actual fact the guidelines is copied, not cut. The original global guidelines remains. Nothing I do will get rid of it.

Then when I then attempt to paste the copied guideline to make it local, it pastes as a global guideline.

Obviously I’m missing something basic here. What is it?


There should be a make local context menu.

Indeed there is. Exactly what that does, I can’t tell. The guideline changes colour to burgundy or violet. Maybe that’s a local guideline pasted on top of a global guideline? In any event even if it is two guidelines, it acts as a single line, with no way to tease two guidelines out of it, if it is two guidelines. If I try to cut it, the line changes colour back to a red global guideline and continues to refuse to be cut or deleted.

I just tried it and it works as expected.
I added a Guide (blue), converted it into a global (red), made a local guide again…

Maybe you have several global guides on top of each other?

What MacOS do you have?
Can you make a screencast?

I’m running Mavericks 10.9.5.

Now that I’ve returned to my test font and Glyphs in the morning the guidelines are now working as expected, except that I’ve had to recreate them.

The local and global guidelines, annotations, backgrounds and glyph sorting order in the Font view that I set before quitting Glyphs last night all disappeared. Are these limitations of the trial version? What other limitations might I come up against?

There are no limitations. You seem to somehow have quit without saving the document.

And please check ‘disable versions’ in preferences > user settings.

Thanks for sticking with me on this, Georg.

Alas, it makes no difference whether Versions are abled or disabled, or whether I do an explicit save or not. Outline edits, kerning and kern groups are saved. Guidelines, backgrounds, annotations and the glyph sorting order are lost.

Do you save as .ufo? They are not supported in .ufo. Please save as .glyphs file. I will have a look if I can store more information in .ufo.

Yes, I’ve been saving as .ufo. I’m new to the UFO format (the reason I’m trying Glyphs), so I don’t know it’s capabilities. I’ve been using the handbook to take me through Glyphs and there’s nothing in it about saving in Glyphs format.

Switching to saving as .glyphs has fixed most of disappearing items so far, except for the not saving the sort order of the glyphs in the Font view. Is there a way to make the order stick?

Yes: glyphOrder parameter.

A bit more explained:

Great. Thank you.