Manually installing vanilla module - 2

Continued from manually-installing-vanilla-module
I’m sorry, but I can do only 3 posts, that’s why I had to open a new one.

It looks like Python is on board:

Python 2.7.10 (default, Oct 23 2015, 19:19:21)
[GCC 4.2.1 Compatible Apple LLVM 7.0.0 (clang-700.0.59.5)] on darwin

And can you post a screenshot of the macro window?

Here’s the Glyphs macro window.

The problem is, there should be a split window, it probably prints error messages but the place where those go are hidden in the collapsed lower part. Can you please try to pull it out of the lower thing? The mouse cursor should change to imply there is a grabber

It’s a bit fiddly:

it’s not fiddly, it’s hidden :wink:

When I enter:
import vanilla
print vanilla

I get:
<module ‘vanilla’ from ‘/Users/user/Library/Application Support/Glyphs/Scripts/vanilla/init.pyc’>

Then everything is fine.

I installed three free plugins, and it does work fine.
But the Show Stems Pro is still not displayed under View. It is installed, I see it under Preferences > Add-ons > Plugins, together with the three plugins I just have installed. Maybe I have to install Show Stems Pro once again …?

And I change the view that it will always visible.

1 Like

There should be an error in the macro window?

There is something in, but I don’t know if there’s a connenction:

could not get ShowVerticalBeam from saved preferences
could not get AngledVBeam from saved preferences
could not get measureOverlaps from saved preferences
could not get showOffPathMeasures from saved preferences

Ahhh, this is related to the register defaults issue, which @mekkablue opened here in the forum recently.

@GeorgSeifert Do you have a clue? This is the first user who reports, that the plugin doesn’t work. All other users had no complaints.

That should be fixed in the latest version.

1 Like

G2.6.2 [1231] macOS 10.13.6 – Having issues with error notices from several plugins, and after removing each of the problem ones, finally down to this in the Macro Panel:

could not get ShowVerticalBeam from saved preferences

Apparently something in Glyphs from 2018 that has popped up again.

That seems to have nothing to do with the topic of the thread. This is an error message from a plugin.

It is the only thread I could find that had the same error message. I’ll try to find a solution.