Mask and shape order

As mentioned in the documentation, a mask should hide everything below it.
But in my case the component above the mask is completely invisible. Even the part, that is not in the mask area.
Did I missunderstand anything?

Can you send me that file?

sent…

Can you try the latest cutting edge version (activate it in Preferences > Updates).

Yes, works. Nice! Thanks!

nevertheless a little bit bumpy. Shape order is not enough to set it right. I have to cut and past the hook, before it is perfect.

The shape order shows the elements kind of backwards. The first and “lowest” item is at the top. I’m working on fixing this. You can use the “Show master compatibility” to add index numbers to the shapes. That helps with the sorting.