Master incompatibility

I have a strange incompatibility issue which shows two extra masters in the ‘shape order’ view which aren’t there. There is a dot in the corner of the bolder master which seems to be causing the problem.

An extra number 2 in the bottom left of this one also.

Can you run “Path” > “Tidy up Paths” (hold down Option to get “Tidy up paths for all Masters”).

Thanks Georg.