Menu order

This is how the font menu look after exporting and setting the style linking.

Italic
Regular
Bold
Bold Italic

The Italic should come after the Regular, how can I achieve that without changing it’s weight to something it’s not?

Didn’t you forget to make a style link properly?

From a forum for another font editor, I found a post where setting the Italic Angle in the metrics settings fixed this particular problem.

Maybe it will work for you.

I styled linked properly. It’s a four family. All short commands for style linking works in InDesign, meaning the Italic is style linked. It’s just the menu that is wrong. I try the Italic angle, maybe that it the problem. Thanks!

It must be some bug, because I did a copy of the font with only two glyphs, and suddenly it worked.

OK, here we go.

Previously the name of the font was XXXX Beta 25 and the menu did not work as expected. All versions had this problem.

I deleted the “Beta 25” in the font name and everything worked.

Good to know.

What happens if you use Beta 26. It might be a cache problem.

I thought so too first, so I did new versions a couple of times with new numbers just to make sure. But it has been like this since Beta 22 when I started working on the italics, so something feels strange.

I also tried renaming the font to something else, and same success there. Maybe it’s related to numbers in font names, or too long font names with numbers?

How long is the font name? Does replacing the numbers with two letters make a difference? Or putting the numbers more to the beginning of the name?

After some investigations.

This did not work:

Xxxx2 Xxxx Beta 26

This worked:

Xxxx2 Xxxx Beta26

and what happens if you use

Xxxx2 Beta 26

basically just use a shorter name.

It may just be that the name is too long.

I ran into that for a client a while back. Worked fine on Mac OS X, but failed on Windows. Admittedly, this wasn’t for style linking, but it sounds like a similar issue.

Tried everything recommended on this forum and in your help docs. Even added a custom weight parameter to each instance. I’m still getting scrambled Adobe font menus, like so (weights in brackets)

Thin [250]
X-Light [275]
Thin Italic [251]
X-Light Italic [276]
Light Italic [301]
Light [300]
Reg [400]
Reg Italic [401]
Medium Italic [501]
Medium [500]
Bold [700]
Bold Italic [701]
Ultra [900]
Black Italic [801]
Black [80]
Ultra Italic [901]

Typeface name is six letters, no spaces.

Any ideas?

Thanks!

The italics should have the same weight class than the upright.

Do you install the fonts in the system or do you use the Adobe fonts folder? https://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps

Sounds like a font conflict. See if you can reproduce it with a different family name. And what Georg said about the weight classes of italics.

When I export straight to the Adobe fonts folder, the problem goes away. (Thanks, Georg.) But will users who drag these fonts into their user/library/fonts folder have the problem I originally had?

I also need to put the font in user/library/fonts to use or test it in Office and other non-Adobe apps. Any problem with my putting copies in both places? It does seem that I have to delete my fonts from the user/library/fonts folder before exporting to the Adobe fonts folder, or the user/library/fonts version seems to override the Adobe/fonts version.

Italics weight classes fixed. I was just trying to get them to follow the romans in Adobe font menus, but it didn’t work.

I can’t get this to break with any other font.

Thanks!

Sorry—you said “different famly name,” not “different family.” I’ll try.

It is not a problem for the user. Only for you if you change the values and the system caches the the old stuff.

I was clearing my caches with FontNuke each time. Maybe FontNuke wasn’t clearing all the caches?

This font cache business is hairy. If I need to debug something in MS Office, I export with a different font name every time (ending up with 100 different fonts; and changing the name to AAA 01 to get it to the top of the list in the font menu).