MergeGlyphs download broken / How to collaborate on Glyphs file?

Hi, as I am looking for a method to collaborate on a Glyphs file and CommitGlyphs appears not to function anymore, I stumbled upon MergeGlyphs on the Glyphs tools page. The download link is broken, though. In case using Edit > Compare Fonts, it also seems to be broken (or, rather, I can’t get it to work). In case anybody can recommend other workflows for remotely collaborating on the same glyphs file, please let me know, as I’m apparently also too stupid to figure out how to use simoncozens’ GlyphsGit.

Thank you!

Your best bet is to use regular Git.

There once existed a beginning of a plugin to do that and it seemed promising but I don’t know where it is now. Glyphs Git doesn’t quite work nowadays, I believe.

Merge Glyphs is quite useful for that comparison.

@mekkablue has a nice Glyphs/Git workflow going.

Be sure so save your file as a .glyphspackage instead of a .glyphs file. This makes working with Git much more pleasant.


Yes, I was looking at that. CommitGlyphs it’s called, I believe. It’s broken, though, which is why I had made a forum post here a few months ago, to no avail. Appears to be deprecated, sadly. Merge Glyphs looks very useful indeed, which is why I’d love to be able to download it :slightly_smiling_face:

What Glyphs/Git workflow does Rainer have?

The MergeGlyphs and CommitGlyphs download links still work fine for me. It must be something on your end.

I had a look at the two apps. It will take some time to update them for Glyphs 3. But I hope I can do that soon.

I’m still on Glyphs 2 and would be very happy to use them in Glyphs 2. But CommitGlyphs always give me the same error: Unrecognised selector sent to instance.

Hi, would it be possible for you to send me the Merge Glyphs installer? I’d appreciate that a lot, because I really can’t figure out how to download it myself. Thanks!


Best to make that request to support at this-domain dot com in case you run into another problem which they are more able to help you with.

1 Like

That doesn’t work for me. Nothing happens (Chrome, macOS Catalina).

Try Safari.

Thanks a lot, for some reason, that worked :slightly_smiling_face: