Minor problems (brace layers; automatic alignment)

I figure none of these are bad enough to justify a thread, but maybe all of them together…?

  1. For some reason, brace layers are treated as subordinate to a certain master. In my case, I had a {32} layer associated with the Regular master. When I copied the Regular master to make a Bold master, the {32} layer was duplicated along with it. Which one is going to be used by Glyphs…?

  2. Similarly, when I duplicate a brace layer for backup purposes, the layer name is still printed in Bold, presumably because it starts with {32}. Again, there is danger that Glyphs and the user disagree on which layer is actually used.

  3. In an unrelated matter, I found it difficult to reinstate automatic alignment in the case of glyphs containing both a component and a path, such as /Q made of /O and a hand-drawn tail. I realize this is bad practice, so probably the issue is not worth addressing. :wink: Still, I had inherited such a /Q from my Regular master in Quinoa. The sidebearings were wrong, since the Bold /O is wider than the Regular one, but simply cutting the tail to the clipboard and choosing «Enable Automatic Alignment» from the context menu didn’t work (the command was ignored and remained available in the context menu). I had to delete the tail and cut-paste the /O to make the Automatic Alignment work again.

(Yes, I promise I will make components for all my /Q-tails in future typefaces…)

  1. Brace layers do not constitute a new font master, they are merely used in the interpolation of that particular glyph, hence it must be marked bold.
  2. That is simply a case of a faulty user entry, which Glyphs cannot prevent.
  3. Which version? That should be fixed in the latest betas.
  1. Still, surely there should never be two identically-named brace layers, as you wouldn’t want there to be two «Bold» masters at any given time. Duplicating a master with a subordinate brace layer does that, though. It could easily be avoided by adding a (1) or a date stamp or something to the duplicated brace layer. Which brings us to…
  2. Not really. When you make a copy of a master (such as «Regular»), the copy is named in a way that keeps it distinct from the active master itself, and that does not usurp its function. Why shouldn’t the same courtesy be applied to copies of an active brace layer? It would be a simple matter of making Glyphs only recognize, e.g., «{32}» as an active brace layer and not something annotated, like «{32} copy» or «{32} 19 Oct 2o16 23:11» etc.
  3. I was using [976].

Cheers!

Digging this thread out for a question:

Are brace Layers actually working in 1189?
I followed the tutorial: copied a master and gave it the name Intermediate {97, 100} 97 which is the exact weight value which I wan to adjust in this glyph. Then I heavily distorted the paths in this layer (still compatible) in order to see a result. But I don’t see anything happening. (I also tried to call it Intermediate {97} because I don’t have a weight axis, and also added an axes parameter for weight and width for testing. No luck here. What am I missing?

Using a bracket Text [97] like so works. It there a difference in the result?

I just tried in 1189, and they do work:

19

I don’t quite understand what your setup is. How many axes? Can you send me the file, maybe?

What do you mean by “copied a master”? You mean master layer?

I just tried and it works fine for me. You don’t need the ,100 and Intermediate. So just {97} should work.

Yes, I meant the master layer was copied. :slight_smile:

Here, can’t make it work. Is the master setup wrong for it?

braceLayer.glyphs.zip (3.2 KB)

The Medium master and the Brace layer have the same coordinate. What are you trying to do?

Maybe that what the bracket layer is for. Maybe I confused them. I think I understand now. This one is supposed to add a master for the glyph which is not existing for the font, right?

That’s right.

1 Like