Missing character when printing

I am encountering a missing character when Printing.
In my Glyphs file, and the exported .otf, the character is present. It is also existing in my InDesign file and exported .pdf. When printing from either the InDesign file or the .pdf, the /p is missing. But when i print it as a Bitmap, the glyph is there. I already tried new InDesign documents and different printers, but the error persists. Can this be connected to something i did in the Glyphs file? Or is the error related to something i am doing wrong elsewhere? I hope you can help me.
Thanks in advance,

Check the paths in the p. Maybe wrong path direction or two paths on top of each other?

They seem to be correct. There are no double paths and Correct Path Direction didn’t change anything.

then it might be a font cache problem. Export the font with a different name.

I tried so. The /p is still missing.

I now took a copy of another font, exported a new .otf und tried to print it. That is working well. But in my typeface the /p still doesn’t print.

If you make other changes and print it, can you see that change? If that stays the same, you’re not seeing the new font.

Yes, the changes are visible. I’m exporting directly into the Adobe Font Folder.

Can you send a screenshot or better the .glyphs file?

Yes, sure

Discorso.zip (25.4 KB)

The p looks just fine in my InDesign.

Works fine for me in InDesign CS6.

In mine too… the problem occurs while printing. But only while printing from an Inkjet printer. While printing with a laser printer or as an bitmap, everything is fine. So it might be a Postscript error?!

For reference, because we just fixed a very similar problem (glyph showing up on screen, but missing PDFs and printouts): It seems to have something to do with bad hints placed in the font file. Fixing was easy:

  1. Deleted and reset Standard H&V Stems in Font Info > Masters (read more)
  2. Deleted all (manually placed) hints in the font with the mekkablue script Hinting > Delete All Hints in Font.
  3. Exported again with autohinting and overlap removal enabled. The glyphs in question reappeared in the PDF.