Missing ligatures in exported OTF file

Hi there. It’s me again.
I designed a font using Fontself extension for AI, and I want now to finalize it with Glyphs.
It is a handwritten uppercase with a bunch of ligatures.
But I have this problem : when I export the OTF file from Glyphs, no more ligatures !

Why does it work when the OTF comes from Fontself, but not form Glyphs ?
What can I do ?

Rename the ligatures, add .liga suffix to glyphs containing ligatures (L_L.liga, L_A.liga), update and compile the “liga” feature at the Features tab of Font info and it should work.

1 Like

Thank you Filip !
I understand the beginning of your tips, but I have to say I’m pretty lost with some of them :sweat_smile:
I can rename and add .liga suffix to my ligatures.
But what means “update” and “compile” ? What are they for ? Where are those functions ?
(Sorry I’m a real newbie…)

I assume you are in Glyphs Mini, which does not offer manual control over the OpenType features. IOW you do not need to update and compile, the app does it for you every time you export.

1 Like

Thank you mekkablue, you’re assuming well :grinning:
So I renamed every ligature X_X.liga, exported the OTF file again but I still don’t have any ligature in Indesign…

I just tried this and it worked for me. Where did you try this? And did you read this:

Georg, you are just amazing :star_struck:

Also, I see you call your ligature e_s.liga, but the image suggests E_S.liga (note the capitalisation) is a better name.

Is the font an all-cap design? Read this then:

It is an all cap font, indeed mekkablue. Thanks for the link, but as it is a handwritten type, I want to keep a handmade feel, that’s why I designed caps that are slightly different from the lowercases. So they can be use as alternates.

Then that may be the reason the ligatures do not work. These sequences are all different:

e s
e S
E s

…and the ligature e_s.liga will only substitute the first of the four.

Thank you mekkablue.
As you thought, the cache was guilty, so I export now directly in the Adobe Fonts folder and every ligature work fine !
I’m struggling now to new problems with the Myfonts font validator :hot_face: