I’m working on a monoline font and I would like to export the font with the stroke at 2 units (or more) but maintaing the Glyph file without offsetting the vectors.
Is it possible to do it with the Custom Parameter?
If so, how?

Property: Filter
Value: GlyphsFilterOffsetCurve; 8; 8; 1; 0.5

… will create an offset of 8 units horizontally; 8 units vertically; create a stroke; equally on both sides. All this happens while exporting. The resulting stroke will be 16 units thick.

Mekka, I tried with your suggestion, but the font cannot be generated. I get this message when I export:
makeotfGlyphs [FATAL] premature end of input
I’m not very skilled with the Custom Parameter, maybe I did something wrong.

Can you send me the Glyphs file?
mekka at myUsername dot com

Sorry, just saw this now: I forgot the semicolon at the end. Maybe that caused the error?

Yes, it was the missing semicolon. Thanks.
One more question: what if I want rounded terminals?

Property: Filter
Value: GlyphsFilterRoundCorner; 30; 1;

30 is the radius, 1 means yes to visual correction (0 would be off).

I don’t understand how to export a monoline font. I’m drawing some letters, some with closed paths, others with open paths. Then I’m applying the filter GlyphsFilterOffsetCurve in Custom Parameter, via File > Font Info > Instances. Finally, I export as OTF (I uncheck the Remove Overlaps option). The result is not a monoline font; the paths are not replaced by the corresponding stroke (Offset Curve): closed paths get filled and open paths disappear. It looks like the filter is not being applied.

I did all this following this tutorial:

What I’m doing wrong?

Did you leave the Remove Overlaps option unchecked as suggested in the tutorial:

Now, when you export your font, the custom parameter will set in and you’ll see your offset active. To export the font, go to File > Export (Cmd-E) and choose a file format. Leave Remove Overlap unchecked, though. Because this option would delete our precious open paths. We suggest to test your font in Adobe programs.

Yes, I did.

I just solved the problem by changing the name of the Instance, from ‘Offset 20’ to ‘Regular’. I don’t know why, but now it works.

Perhaps clean out your Temp folder:

~/Library/Application Support/Glyphs/Temp/

Thanks for your help, @mekkablue :slight_smile: