MS Word not supporting multilingual font


I designed an Arabic font and merged my Arabic glyphs with an Open Font License Latin font.
I exported TTF and OTF fonts and they works fine in Adobe apps such as InDesign and Illustrator, also it works fine in Apple Pages.
My problem is with Windows MS Word, I can write Arabic but not latin!!!

In instances, I added: TTFAutohint options and activated Windows Compatibility .
Also in Features I updated the Languagesystem with the following values:
languagesystem DFLT dflt;
languagesystem arab dflt;
languagesystem hebr dflt;
languagesystem arab URD;

Now, How can I write in both languages (Arabic + Latin) in Windows MS Word?

Thank you,

What do you have for codePageRanges and unicodeRanges ?

Thank you BobH for your quick replay,

In Master I have the following:
unicodeRanges: Basic Latin, Latin-1, Latin Extended-A, Latin Extended-B, Spacing Modifier Letters, Greek, Arabic, General Punctuation, Currency Symbols, Letterlike Symbols, Mathematical Operators, Geometric Shapes, Private Use Area (plane 0), Alphabetic Presentation Forms-A, Arabic Presentation Forms-A, Arabic Presentation Forms-B.

And for codePageRanges:
Latin 1, Arabic, Arabic; ASMO 708.

Thank you,

What about removing the settings and left makeOTF compute them for you automatically? And make sure you read this:

Many Thanks Georg,
Will check and get back.


Can you update your languagesystems, and let it happen automatically, because latn is missing.

Thank you mekkablue for your add
but how can I add “latn”?
When I add it ti to Languagesystem then update, it automatically disappear !!!

How to add makeOTF?

My problem is with Windows platform not Mac.

Glyphs uses makeotf to compute some of the final settings during export of the font files. So, Georg was suggesting not setting the various configs like codePageRanges, unicodeRanges, etc., letting them be automatically set during export.

Click the Update button, a Languagesystems entry will appear, which contains all the scripts in your font. Apparently you have another, manual Languagesystems entry. Delete or deactivate that one.

In File > Font Info > Font, delete the Code Page and Encoding Custom Parameters.

I did what you suggested and now I have:
languagesystem DFLT dflt;
languagesystem arab dflt;
languagesystem arab URD;

But still without “latn”?

Thank you Composerjk
You mean it’s automatic config, so I do not need to add parameters?

Is it possible you do not have any Latin-spacific features?

Ok, What is Latin-spacific features?

Sorry for the typo, that was meant to be specific. What I meant was open type features specific to Latin. Do you have any in your font file?

I have only the Basic latin and Arabic letters, Numbers, Fraction, Punctuation, Symbols and Combining.

Can you send me the .glyphs file please to support (at) (this website without www). I will have a look.

Ok, File sent
Thank you mekkablue

Can you send again? I have not received anything; support at glyphsapp dot com.