Multiple masters not compatible

I don’t get what’s missing, that it’s still not compatible?

The path order is wrong. check the “2” and “3”. Select a node and follow the line that connects to the other masters. Then press tab to stepp through the nodes. That should illustrate what is currently connected. have you read this:

Thanks George!
How do I change the order? (Pfadrichtung korrigieren) doesn’t do anything)

You can use the Fix Compatibility filter.

Hold down the Option key when you correct path direction. That applies it to all masters.

There is no change if I try to fix it with the compatibility filter…

The small segment (marked red in the screenshot) is a line. The corresponding segment in the light master is a curve. And because the two segments are very different in size, the interpolation would not be very good. I would cut out the stroke and overlay it. That way the curve can interpolation properly.

You can use the “Reconnect Nodes” command. Select two nodes where the stroke enters the O-shape, right click and run “Reconnect Nodes”.

I see. Now it’s working. Thanks!
Just one more question: Don’t I have to remove overlaps before exporting?

No. The overlap will be remove during export. You might have noticed the checkbox in the export dialog.