My first plugin: Show Stem Thickness


#21

One rude question :slight_smile: : have you added dragging?


#22

I’ve liked using this plugin a lot so thanks for making this!

But know after I updated my Glyphs to Version 2.5b (1104) this stopped working. Is it just me or does this plugin have some conflict with the latest version?


#23

Show Stem Thickness actually quit working at Build 1103. I filed an issue with the author on github but haven’t seen a fix yet. I am staying with Build 1101 until it is fixed because I use it daily.


#24

I noticed the same thing. I went back to 2.4.4 (1075) for now because I did enjoy the Show Stem Thickness to always be ‘passively measuring’ as I pass my mouse over the current glyph. Hope the plug-in owner can update it before 2.5 comes out officially!


#25

I send a pull request that fixes it.


#26

Thanks Georg.


Stem thickness plugin not working in latest 2.5b versions 1104 and 1105
#27

Thanks @GeorgSeifert, Sorry guys for slow responding and not updating the plugin, I’m studing again and I have problems with managing time


#28

Totally understandable Rafal.

It seems there is a new problem though. I just added a new issue for the new merge for you to look at.


#29

I’m also having trouble using Show Stem Thickness. (A great Plug-in by the way, I usually have it on all the time – many thanks!) It works again, but only partially: Shows thickness between two straight lines or between straight and curve, but no result between two curves. I am using Glyphs Build 1105.

Appreciate any help!


#30

I send a fix already. I’m not sure if it is applied yet. But try updating once in a while.


#31

It has not been merged yet. In addition I sent a reply to you about another issue with it, but I sent it as a reply to a github notification of your commit. Should I resend it to you at support?


#32

I did send another pull request that should fix this.


#33

The last one I see is #10, which is where the new problem shows up.


#34

I don’t understand. With #10 the plugin works fine for me.


#35

It measures fine for me too, but I discovered something new (to me) about it. This may have been the behavior in previous versions and I just didn’t notice it.

In views in a glyph window above 6000 pts the measured width numbers begin to go outside the background panel. I did some more tests this morning and see now that while the plugin background panel isn’t tied to a grid, the width number is (base aligned), even if the user has grid/steps set to 0/0. Here’s a screen shot of two instances:


#36

This is a problem in my code. I fixed it.


#37

Thank you Georg.


#38

Rafal has merged #10.


#39

I probably hadn’t updated the Plugin correctly, sorry! It works fine for me as well now.

Thank you everybody!


#40

Hi Rafal!

I’ve really enjoyed your plugin. However I was unable to update to the latest version. I run the Glyphs update to version 2.5.2. and updated the plugin to the latest version available but it doesn’t come up in view menu. (I’m running mac on El Capitan 10.11.) I tried installing the plugin both according the instructions from plugin manager and manually overring the plugin (and repository) files.

Let me know if there’s something I’m missing, I couldn’t figure this one out myself. I was looking forward to setting up the guidlines with the latest update. I had to revert to a version from last June that I had stored, but for some reason that doesn’t support the live measuring by hovering.