Myfonts glyphs contours error!

Hello again, folks!

I finally finished my typeface, so I tried to upload it to the MyFonts platform.

Almost everything passed on the tests, but, strangely, for one of the masters, the Light version, I got the following error:

Glyph contours have correct winding directions

To ensure proper functionality for customers, the paths in your glyphs must have correct winding directions. Wrong path directions can mess up counters. Paths need to be oriented counter-clockwise, counters need to be oriented clockwise. For more information about how to fix this issue, please see our help article.

The problem is that I double checked both files for the masters (Bold and Light) and all the glyphs have the same directions and contours! It’s weird, because, if one master has passed, why not the other one, if they were created from the same glyphs? I don’t know what else can I do to fix it…

Could someone helpe me, please?

This might be caused by a tiny self overlap.

Well… unfortunately I can’t find any of this overlaping…

have you found the source of the error?

Or duplicate paths. The Path Problem Finder script can find those.

Hi, I tried running the Path Problem Finder script for the same issue as listed above, but got this error:

ModuleNotFoundError: No module named ‘vanilla’

Any advice on running this script?


You can install the vanilla module in the Plugin Manager > Modules (or in Preference > Addons > Modules if you are in Glyphs 2).

I pick up the topic because I’ve got the same problem. Myfonts Validator gives a winding direction error at only 1 of 36 fonts. All fonts work as expected and Interpolate in the correct way.

I used “correct path direction” (more than once) but it persists and The Path Problem Finder script doesn’t work even though I installed the modules.

What do you mean “it doesn’t work”? What is displayed in the macro window?

Excuse me, I should have explained better. This is the error in the macro window.

Captura de Pantalla 2022-11-04 a las 21.32.42

You have an outdated version of the scripts installed. Please remove your current mekkablue scripts, and reinstall them via Window > Plugin Manager.

1 Like