Nested components not visible


I have denominators. one.dnom is composed from a stem and two serif-components. When I nest one.dnom in onehalf fraction glyph and onehalf glyph in onehalf.osf - serif components are gone.

Why is that?

Can you send the .glyphs file to support at this domain? We’ll take a look.

I sent a file. Thanks.

You can only nest 3 levels down.

In your case, the onehalf is only shifted down. You do not need a separate glyph for that, you could solve this with a GPOS feature. Add this line to your onum feature:

pos [onehalf onethird onequarter] <0 -100 0 0>;

Add additional glyph names into the bracket expression.

If you do want to keep it as a separate glyph, duplicate (cmd-D) onehalf into onehalf.osf, add a single node to the glyph (will be deleted at export when overlaps are removed), and then you can shift down everything. This way you prevent going into the fourth nesting level.

Thanks. I will use GPOS feature.


In Glyphs 4level nested components are not visible, but in the font are ok. I mean that in Illustrator/InDesign are ok.

In Glyphs GPOS feature doesn’t change a position of the glyph, while in indesign or illustrator it does.

Oh, that is possible. I have never gone that far with nesting.

And about the positioning features: yes, Glyphs does not preview GPOS features except for kerning. You’ll have to do that with the Adobe fonts folder:

That last answer also solved one of my troubles :slight_smile: thanks.
I hope glyphs will support that in the future (as an option, with the possibility to turn it off…)

For now I uses the same layout in the edit view and the preview. I will not implement full GPOS support in the edit view for various reasons (e.g. it would be distracting if mark glyphs would jump around) but I could enable it in the preview. But that needs quite a lot work so it will not happen any time soon.